SiteMapProvider was not found error?

Nov 12, 2010 at 12:43 PM

Tried to run Officer2010 and got an exception in Application ctor.

The type 'XamlSiteMapProvider' was not found. [Line: 13 Position: 35]

Coordinator
Nov 12, 2010 at 1:20 PM
Edited Nov 15, 2010 at 9:55 AM

I believe by default nRoute's dll file (nRoute.Framework.dll) is not included in the download, so just add that (note, the Silverlight version) and it should work.

Cheers,
Rishi 

Dec 13, 2010 at 4:27 PM

HEllo,

 

i tried to run nRoute.Samples.SiteMapExample and i have the same error. I build nroute.framework.dll on lastest version from codeplex source code and the same result when i run the sample.

Best regards

Marc

Coordinator
Dec 13, 2010 at 8:40 PM

I just downloaded and build the project by adding "nRoute.Framework.dll" by adding to ".\Officer2010 v2\Referenced Assemblies" folder, and it ran just fine. Make sure you don't have any references missing, open the references folder in VS and check if any reference has an warning icon next to it. The most likely culprit might be System.Observable.dll since the released version has changed, so double check that. 

Cheers,
Rishi 

Dec 14, 2010 at 9:18 AM

Hello,

 

i just tried to run the samples and now it's works, i don't have make some changes in VS Solution or project but it's works.

Thanks for your quickly answer.

 

Best regards,

Marc

Dec 28, 2010 at 2:30 PM

I have everything installed and it does not work.  Tried with netflix sample, same problem. Well actually it is not same immediately. First I get errors that MainPage.g.i.cs is missing a using directive.  For some reason it does not add "using nRoute.Controls" from xaml correctly. So i add it manually, choose to not refresh the file and than run it, and I get the above XamlSiteMapProvider was not found. I have references to System.Observable version 1.0.0.204.  No other references are broken. Tried downloading dll and placing them in "Referenced Assemblies" folder, it did not work. Tried making a reference to project, same thing. Really frustrating...  

Coordinator
Dec 29, 2010 at 12:07 PM

Hi Epitka, I'm pretty sure it is working - I just downloaded the project, added references to nRoute.Framework.dll to both the SL projects, and it seems to be working fine. For your convince, I've uploaded my working version with the dll references in tact here: http://cid-587cbdf035b4a11d.office.live.com/self.aspx/.Public/Silverlight%20Netflix.zip

See if it works for you.

Cheers,
Rishi

Dec 29, 2010 at 12:32 PM

Wow, thank you for going extra step. I downloaded it and it works. Now off to figure out why is it not working with the other download. I am sure that I messed something up :)